Page 2 of 6 FirstFirst 1234 ... LastLast
Results 17 to 32 of 82

Thread: Schuberth C4 & SC-1 Comms

  1. #17
    Subscriber Click here to find out how to Subscribe
    Join Date
    Feb 2017
    Location
    The Hague, Holland
    Posts
    264
    Quote Originally Posted by Arsey View Post
    Just got my C4 and SC1 Standard from Pete at Just Helmets.

    Great service as always.

    A question for those of you who have them-I've connected my iphone and it all works ok.BUT I made call and it worked fine but the person I was calling said it was quite muffled and he couldn't hear me very well.Also,when I say something to myself,ie when not on a call,I can hear myself through the speakers as though the mike is always live.Is this normal ? Ta
    Not normal! I set up my system and the recipient of my call could hear me loud and clear. Not sure about the bike to bike comms however the SC1 has a unique HD feature which means for the intercom the sound quality is classed as HD. Need to test this one out shortly with a pal who also has the SENA communication system on his BMW lid.
    Let you know

  2. #18
    Subscriber Click here to find out how to Subscribe
    Join Date
    Mar 2008
    Location
    Guernsey or on another beach...
    Posts
    9,931

    Schuberth C4 & SC-1 Comms

    Quote Originally Posted by grantmac View Post
    Not normal! I set up my system and the recipient of my call could hear me loud and clear. Not sure about the bike to bike comms however the SC1 has a unique HD feature which means for the intercom the sound quality is classed as HD. Need to test this one out shortly with a pal who also has the SENA communication system on his BMW lid.
    Let you know
    It's all ok now.I think I had the intercom triggered as I had pressed the '-' button.
    The speakers are good but the mike isn't as clear as it could be.Other than that it seems great.And best of all it paired properly with the My Ride feature on my KTM 1290R,unlike my Scala Packtalk so I can play music,make calls etc using the left grip buttons and with everything showing on the dash.

    Happy days.


  3. #19
    Subscriber Click here to find out how to Subscribe
    Join Date
    Dec 2016
    Location
    Manchester
    Posts
    122
    Quote Originally Posted by Arsey View Post
    It's all ok now.I think I had the intercom triggered as I had pressed the '-' button.
    The speakers are good but the mike isn't as clear as it could be.Other than that it seems great.And best of all it paired properly with the My Ride feature on my KTM 1290R,unlike my Scala Packtalk so I can play music,make calls etc using the left grip buttons and with everything showing on the dash.

    Happy days.

    Wow - I like that picture. Makes my GS look very old fashioned.



    Sent from my iPhone using Tapatalk

  4. #20
    Subscriber Click here to find out how to Subscribe
    Join Date
    Dec 2016
    Location
    Manchester
    Posts
    122
    Quote Originally Posted by Qjumper View Post
    Thanks for that. I'll take a trip to B&Q this weekend!


    Sent from my iPhone using Tapatalk

  5. #21
    Subscriber Click here to find out how to Subscribe
    Join Date
    Mar 2016
    Location
    Hertfordshire
    Posts
    1,156
    Quote Originally Posted by Arsey View Post
    Just got my C4 and SC1 Standard from Pete at Just Helmets.

    Great service as always.

    A question for those of you who have them-I've connected my iphone and it all works ok.BUT I made call and it worked fine but the person I was calling said it was quite muffled and he couldn't hear me very well.Also,when I say something to myself,ie when not on a call,I can hear myself through the speakers as though the mike is always live.Is this normal ? Ta
    Mikes are behind cheek pads.

    Re hearing your self, I have same issue with my sena 10u. Puzzled by that to be honest.


    Sent from my iPhone using Tapatalk
    All the best.....

    EV

  6. #22
    Subscriber Click here to find out how to Subscribe
    Join Date
    Feb 2017
    Location
    The Hague, Holland
    Posts
    264
    Something also interesting, the remote for the SC1 that I bought is not rechargeable but uses 1 x CR2016 cell battery. No idea how long these last when in constant connection with my comms but I have bought a few extra and take them along just in case. Luckily the unit will show you when the battery is almost dead by giving a power indication upon start up.

  7. #23
    Subscriber Click here to find out how to Subscribe
    Join Date
    Mar 2008
    Location
    Guernsey or on another beach...
    Posts
    9,931
    And where's the bloody app ?

    SC1 instructions say go to app store and download SCHUBERTH app,but I'm buggered if I can find it.Don't need it anyway as all working,but even so.....

  8. #24
    Subscriber Click here to find out how to Subscribe
    Join Date
    Dec 2016
    Location
    Manchester
    Posts
    122
    Quote Originally Posted by Arsey View Post
    And where's the bloody app ?

    SC1 instructions say go to app store and download SCHUBERTH app,but I'm buggered if I can find it.Don't need it anyway as all working,but even so.....
    It's the SENA app you need. I used it to do config of the helmet and set radio stations. Couldn't get the helmet to connect to my Mac


    Sent from my iPhone using Tapatalk

  9. #25
    Subscriber Click here to find out how to Subscribe
    Join Date
    Mar 2008
    Location
    Guernsey or on another beach...
    Posts
    9,931
    Quote Originally Posted by DottyDog View Post
    It's the SENA app you need. I used it to do config of the helmet and set radio stations. Couldn't get the helmet to connect to my Mac


    Sent from my iPhone using Tapatalk
    OK ta.

  10. #26
    Subscriber Click here to find out how to Subscribe
    Join Date
    Jan 2002
    Location
    In my woods, halfway up Ben Aigan, Moray
    Posts
    609
    First ride out today wearing my C4. Got to say it seems to become more comfortable quite quickly. Helmet itself seems well made, but I too found it difficult at times to tell if the chin vent was open. Good airflow over the top of the head.

    Typical Scottish day, so didn't really get to try the sun visor, but I can testify that I didn't get torrents of rainwater running down the inside of the visor. What I did get however, can be seen in this photo.



    The misting was below my sight line, but I still wouldn't expect it in a helmet of this price.

    Regarding the noise level, bearing in mind I'm comparing it with an old System 5, I found it quite a bit quieter, but I never used to use the removable chin skirt on my old helmet, so that may explain it.

    Something to be aware of if you need the XL upwards, is that it is an extremely tight fight into the standard GSA topbox.

    Regarding the comms, when working they were very good, crystal clear on GPS instructions, music, phone and also rider-rider intercom. The buttons are small, and quite awkward to reach, so perhaps consider the remote. I would have done, but don't like the thought of paying £100 for the Schuberth version when the SENA 10U includes it in the price. Any problems that I had with making calls etc may be down to my lack of familiarity, so I'll hold back on commenting yet.



    Iain
    If you can't do it anymore, teach it

  11. #27
    Subscriber Click here to find out how to Subscribe
    Join Date
    Mar 2008
    Location
    Guernsey or on another beach...
    Posts
    9,931

    Schuberth C4 & SC-1 Comms

    Had mine for a day or so and liking it so far .
    Agree about the chin vent and not sure if it's open or closed but the rest I'm liking so far,but obviously early days.
    No misting on my visor ,but it was a lovely day here.
    I find the controls are ok and when I'm riding my 1290,then I can control everything through the left hand switch gear anyway.

    It seems quite light and quieter than my Neotec ,as I think the pads hug the ear area more.Nice and plush and well made.

    Speaker quality seems very high and I love the integration of the SC1

  12. #28
    Subscriber Click here to find out how to Subscribe
    Join Date
    Jan 2002
    Location
    In my woods, halfway up Ben Aigan, Moray
    Posts
    609
    Just been looking at my visor this morning, and there is a clear gap at the bottom of the Pinlok insert, which I imagine will not be doing much good.

    Of interest, the L helmet, which I am sending back, doesn't have this gap. For anyone else with a misting problem, it may be worth checking how well the insert is fitted.

    Iain
    If you can't do it anymore, teach it

  13. #29
    Subscriber Click here to find out how to Subscribe
    Join Date
    Mar 2016
    Location
    Hertfordshire
    Posts
    1,156
    Quote Originally Posted by The Stimulator View Post
    Just been looking at my visor this morning, and there is a clear gap at the bottom of the Pinlok insert, which I imagine will not be doing much good.

    Of interest, the L helmet, which I am sending back, doesn't have this gap. For anyone else with a misting problem, it may be worth checking how well the insert is fitted.

    Iain
    You may need to rotate retaining pins to release tension on pinlock


    Sent from my iPhone using Tapatalk
    All the best.....

    EV

  14. #30

    SC1 Advanced - Not Discoverable on any Device?

    Hi Looking for any tips to resolve pairing the SC1 Advanced with my phone(s)

    Have charged the unit up, have updated the Firmware via a PC, (Nothing worked using my MAC)

    tried several phones and two laptops (a PC & a Mac) the SC1 is not discoverable on any Bluetooth Devices?

    I've read the Manual,
    5.1.1 - "Configuration Menu" works
    5.1.2 - "Phone Pairing" works
    5.1.3 - Search for Bluetooth Devices - Select the SC1 - no devices at all will find the SC1?

    Tried to do a Factory Reset 14.18 but can't get to to say "Factory Reset" from tapping the "+" button as stated?

    Anyone had this and have a solution or workaround please?

    Cheers, Jonno
    Cars & Vans for a living, Bikes to feel alive!

  15. #31
    Subscriber Click here to find out how to Subscribe
    Join Date
    Jan 2002
    Location
    In my woods, halfway up Ben Aigan, Moray
    Posts
    609
    Jonno, I found that it wouldn't pair initially with my Nav V, just never showed on the Nav list of devices. Recycled Nav and SC1, then for some reason everything worked fine, and it has connected properly each time since.

    Had a couple of drops of Bluetooth between Nav V and SC1, but switching off Bluetooth from menu on Nav and then recycling it cures that.

    Phone connection (iPhone 6S) has been pretty stable.

    Iain
    If you can't do it anymore, teach it

  16. #32
    Subscriber Click here to find out how to Subscribe
    Join Date
    Oct 2005
    Location
    Moray - Centre of the Universe...
    Posts
    508

    Click here to find out how to remove these ads

    Quote Originally Posted by The Stimulator View Post
    Jonno, I found that it wouldn't pair initially with my Nav V, just never showed on the Nav list of devices. Recycled Nav and SC1, then for some reason everything worked fine, and it has connected properly each time since.

    Had a couple of drops of Bluetooth between Nav V and SC1, but switching off Bluetooth from menu on Nav and then recycling it cures that.

    Phone connection (iPhone 6S) has been pretty stable.

    Iain
    And your set-up connects up easily and with great clarity to my E1/10U Sena set-up too Iain :-)
    “I have no reason to go, except that I have never been, and knowledge is better than ignorance. What better reason could there be for travelling?”
    ― Freya Stark, A Winter in Arabia

Page 2 of 6 FirstFirst 1234 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Anyone attending a Ride Out or Event organised through the UKGSer Forums does so at their own risk.
UKGSer.com or anyone organising an event posted here will not be held responsible in any way for damage or personal injury sustained while attending any such events.

Members attending any such event do so at their own risk.

The text, images, graphics, sound files, animation files, video files, and their arrangement on this Website are all subject to copyright and other intellectual property protection. These objects may not be copied for commercial use or distribution, nor may these objects be modified or reposted to other sites without prior written permission.

Disclaimer: Use or depiction of the BMW logo or trademark throughout this web site is for illustrative and editorial purposes only, and to the benefit of the trademark owner, with no intention of infringement of the trademark.

The UKGSer Forums may include adult content for which it cannot be held responsible. Your use of this website constitutes acceptance of the UKGSER network privacy policy

"Its about being a grown up hooligan - and if that means a dark visor, remus open pipe and a bit of speeding out of town then all well and good"