Page 3 of 5 FirstFirst 12345 LastLast
Results 33 to 48 of 73

Thread: Schuberth C4 & SC-1 Comms

  1. #33
    Quote Originally Posted by The Stimulator View Post
    Jonno, I found that it wouldn't pair initially with my Nav V, just never showed on the Nav list of devices. Recycled Nav and SC1, then for some reason everything worked fine, and it has connected properly each time since.

    Had a couple of drops of Bluetooth between Nav V and SC1, but switching off Bluetooth from menu on Nav and then recycling it cures that.

    Phone connection (iPhone 6S) has been pretty stable.

    Iain
    Resolved! Combination of poorly written instructions & User Error, thanks Iain
    Cars & Vans for a living, Bikes to feel alive!

  2. #34
    Subscriber Click here to find out how to Subscribe
    Join Date
    Aug 2010
    Location
    St Briavels
    Posts
    66
    I too have gone the C4 route with SC1. Done about 200 miles in mine so early days. Sizing is same as C3 and C3Pro as far as I can tell - in a medium. Love the helmet - improved field of vision especially. Comms work fine. No probs with pin block visor either. Excellent, quiet helmet.
    And, like others, a big thumbs up for Pete at Just Helmets. Excellent service, great advice. Helmet arrived exactly when promised. Can't recommend Pete highly enough.

  3. #35
    Subscriber Click here to find out how to Subscribe
    Join Date
    Jan 2002
    Location
    In my woods, halfway up Ben Aigan, Moray
    Posts
    600
    Just in case anyone is concerned, twisted the Pinlock pins slightly, and now have a far better seal. 350 mile ride today from Morayshire (4.5 deg this morning) to Dent through rain and shine, with no misting at all.

    If you can't do it anymore, teach it

  4. #36
    Subscriber Click here to find out how to Subscribe
    Join Date
    Mar 2008
    Location
    Guernsey or on another beach...
    Posts
    9,268

    Schuberth C4 & SC-1 Comms

    I've used my C4 for a good few hundred miles now.

    Got caught in huge storm today.

    All good really !!

    The SC1 connects quickly every time to my bike and the speakers are very good.I also wear custom ear plugs but can hear music up to about 70mph.Obviously it's much louder without the ear plugs.
    Ventilation is simple and works well,once you realise how easy the chin vent works.

    The pinlock isn't misting up at all and the helmet didn't leak a drop in VERY heavy rain.

    Comfort is high too,with plush lining.
    It's quite light considering it has comms and speakers built in,and quiet enough and seems well built.

    It bloody well should be for the price but I'm impressed so far.

  5. #37
    Subscriber Click here to find out how to Subscribe
    Join Date
    Feb 2017
    Location
    The Hague, Holland
    Posts
    236
    Yesterday took the new lid (C4) out for its first ride along the canals & waterways of central Holland. All in all pretty impressed.
    Here are my points:

    Lid itself fits great and is quite a bit quieter than my normal M1. No fogging - well it was 20 degrees but then again I sweat quite a bit so fogging is almost always a problem for me. Front vent works fine although cant really notice the airflow. Don't share the points before of not knowing when its open or closed. To me pretty straight forward really. Top vent is much better allowing a nice airflow into the top of the lid.
    Field of vision is excellent. Flip lid can stick sometimes when trying to open which I did find awkward. Not sure why.

    Anyway about the comms. It all took a bit of getting used to but in fact with the remote control unit things are quite easy. Must say I'd be lost without the remote. The 2 buttons on the lid itself for me would be a nightmare. Remote fits nicely onto the left grip next to the flywheel for the navigation. No hindrance to the gear leaver or indicator.

    - The Bluetooth connection works really well. Everything pairs nicely, iPhone, GPS and remote. Remote takes the longest to pair - probably a few mins, so be patient when first setting off if the remote seems not to be working. Give it a few minutes to connect.

    - SC1 seems only to announce when 1 component is paired and not the 3 I have - iPhone, remote and GPS so you don't know if all is working until you try them.

    - Pairing is so much better than on my SRC system from Cardo which I have on my M1. SENA seems to have this one really sorted. Could also have to do with the fact that all batteries were fully charged at the beginning of the day but even at the end of the ay pairing worked fine.

    - One slight concern is that when I started the day I got 3 ''flashes'' on the remote to show the battery was full but at the end of the day only 2. seems to contradict the point made earlier about the lithium battery in the remote lasting 5 months..... Lets see how it goes.

    - Regarding the functions, radio is excellent with RDS and bandwidth announcement when you scan.

    - Volume easy to manage with the remote. Tiny delay when you hit the "+" or "-" button on the remote before the volumes changes which I kinda like.

    - Telephone connection is clear and easy to manage again with the remote.

    - General sound quality is also top.

    All in all nothing really to really fault it at this stage.

  6. #38

    Advice required pairing to Nav 5

    Anyone tell me what I'm doing wrong please? I have paired my SC1 Advanced on the C4 Helmet to my two i-phones and calls are all ok on both. Have paired it to the Nav 5 which 'sees' the SC1 says connected then after a second changes to unconnected. (The Nav 5 is also paired to one of the phones.) Result is that the Nav5 is not sending any voice commands to the helmet.

    Anyone able to offer some advice to me please?
    Cars & Vans for a living, Bikes to feel alive!

  7. #39
    Subscriber Click here to find out how to Subscribe
    Join Date
    Jan 2002
    Location
    In my woods, halfway up Ben Aigan, Moray
    Posts
    600
    Quote Originally Posted by Jonno58 View Post
    Anyone tell me what I'm doing wrong please? I have paired my SC1 Advanced on the C4 Helmet to my two i-phones and calls are all ok on both. Have paired it to the Nav 5 which 'sees' the SC1 says connected then after a second changes to unconnected. (The Nav 5 is also paired to one of the phones.) Result is that the Nav5 is not sending any voice commands to the helmet.

    Anyone able to offer some advice to me please?
    May not be helpful Jonno, but I thought the pairing option was for one phone and one phone/gps i.e. 2 devices. If that is the case it seems to me you may not have the pairing options to do what you want.

    For what it's worth, I have an iPhone paired to the SC-1, and my Nav 5 paired to the SC-1. Although I would like to run the phone through the GPS in order to get the call handling I read that this may not be the best option.
    If you can't do it anymore, teach it

  8. #40
    Subscriber Click here to find out how to Subscribe
    Join Date
    Feb 2017
    Location
    The Hague, Holland
    Posts
    236
    same here and it didn't work for me unfortunately so I went for the option using the SC1 as hub.
    With quick dial it works fine but I would have preferred to go through my ZUMO for the phone calls.

  9. #41
    Subscriber Click here to find out how to Subscribe
    Join Date
    Jan 2002
    Location
    In my woods, halfway up Ben Aigan, Moray
    Posts
    600
    Quote Originally Posted by grantmac View Post
    same here and it didn't work for me unfortunately so I went for the option using the SC1 as hub.
    With quick dial it works fine but I would have preferred to go through my ZUMO for the phone calls.
    Grantmac, how are you finding using the buttons on the helmet, or did you go for the remote control?

    Iain
    If you can't do it anymore, teach it

  10. #42
    Subscriber Click here to find out how to Subscribe
    Join Date
    Feb 2017
    Location
    The Hague, Holland
    Posts
    236
    Hi Iain

    I have the remote. The buttons on the SC1 are far too fiddly. The remote really works a treat! See post 5 above for more details

  11. #43
    Subscriber Click here to find out how to Subscribe
    Join Date
    Feb 2017
    Location
    The Hague, Holland
    Posts
    236
    ...and before anyone asks I am referring to the one below which is the recommended one that Schubert sells as part of its C4 comms set up.
    Its basically the SENA RC4

  12. #44
    Subscriber Click here to find out how to Subscribe
    Join Date
    Feb 2017
    Location
    The Hague, Holland
    Posts
    236
    adding the photo of how it all arrived with me showing the remote box.
    Attached Images Attached Images  

  13. #45
    Subscriber Click here to find out how to Subscribe
    Join Date
    Jan 2002
    Location
    In my woods, halfway up Ben Aigan, Moray
    Posts
    600
    Quote Originally Posted by grantmac View Post
    ...and before anyone asks I am referring to the one below which is the recommended one that Schubert sells as part of its C4 comms set up.
    Its basically the SENA RC4
    Grant, does the remote fit well on the left grip near the whirly wheel or is an awkward fit? Any chance you could take of photo and post it here sometime.

    Thanks

    Iain
    If you can't do it anymore, teach it

  14. #46
    Subscriber Click here to find out how to Subscribe
    Join Date
    Feb 2017
    Location
    The Hague, Holland
    Posts
    236
    Sure, will do but to answer your question, yes, it fits fine. I have it up against the flywheel and at a slight angle.
    Makes the indicator button a tad further to reach with my thumb but that's small fry compared to the ease of using it.

  15. #47
    Subscriber Click here to find out how to Subscribe
    Join Date
    Jan 2002
    Location
    In my woods, halfway up Ben Aigan, Moray
    Posts
    600
    Quote Originally Posted by grantmac View Post
    Sure, will do but to answer your question, yes, it fits fine. I have it up against the flywheel and at a slight angle.
    Makes the indicator button a tad further to reach with my thumb but that's small fry compared to the ease of using it.
    Thanks Grant. Ordered one today from Pete, hopefully won't have too long to wait for it.
    If you can't do it anymore, teach it

  16. #48
    Subscriber Click here to find out how to Subscribe
    Join Date
    Sep 2013
    Location
    Dorset, England
    Posts
    172

    Click here to find out how to remove these ads

    Quote Originally Posted by Arsey View Post
    It's all ok now.I think I had the intercom triggered as I had pressed the '-' button.
    The speakers are good but the mike isn't as clear as it could be.Other than that it seems great.And best of all it paired properly with the My Ride feature on my KTM 1290R,unlike my Scala Packtalk so I can play music,make calls etc using the left grip buttons and with everything showing on the dash.

    Happy days.

    Do you have a Sat Nav (which type?) paired with your phone/headset system? If so, when you receive a call, does it show on both the Sat Nav and My Ride?

    I have been unsuccessful in playing music via My Ride and have abandoned using My Ride with my Cardo Sho-1 / TomTom Rider 400 set up.

Page 3 of 5 FirstFirst 12345 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Anyone attending a Ride Out or Event organised through the UKGSer Forums does so at their own risk.
UKGSer.com or anyone organising an event posted here will not be held responsible in any way for damage or personal injury sustained while attending any such events.

Members attending any such event do so at their own risk.

The text, images, graphics, sound files, animation files, video files, and their arrangement on this Website are all subject to copyright and other intellectual property protection. These objects may not be copied for commercial use or distribution, nor may these objects be modified or reposted to other sites without prior written permission.

Disclaimer: Use or depiction of the BMW logo or trademark throughout this web site is for illustrative and editorial purposes only, and to the benefit of the trademark owner, with no intention of infringement of the trademark.

The UKGSer Forums may include adult content for which it cannot be held responsible. Your use of this website constitutes acceptance of the UKGSER network privacy policy

"Its about being a grown up hooligan - and if that means a dark visor, remus open pipe and a bit of speeding out of town then all well and good"