Results 1 to 5 of 5

Thread: New guy looking to fix an ABS 2 unit

  1. #1
    New Member (less than 15 Posts)
    Join Date
    May 2018
    Location
    Greece
    Posts
    1

    New guy looking to fix an ABS 2 unit

    Yo people , thanks for the add.....be gentle...please. I have a 2000 1150 GS and the non servo ABS 2 unit has packed up and won't do anything anymore. The bike has 66k on the clock and this happened while on a tour in Greece. A little bit of black tape to hide the flashing lights is getting old...and I'm looking to send the unit somewhere in Europe to get fixed because apparently nobody in this country fixes ABS units.... Can anyone recommend a reputable company that I could courier the unit to that won't break the bank? I chatted with a place called Autotronics in the UK who claimed they could fix it for 240 quid plus shipping...with a one week turn around. Can anyone confirm if this place is legit , or suggest an alternative ? TIA for any info. Stay safe out there.... Dan

  2. #2
    Subscriber Click here to find out how to Subscribe
    Join Date
    Aug 2016
    Location
    West Sussex
    Posts
    1,723
    Servoectomy - £60 about a couple of hours turnaround.

    Do a search,

  3. #3
    Subscriber Click here to find out how to Subscribe
    Join Date
    Jan 2009
    Location
    Co. Meath Irish Rep.
    Posts
    5,178
    Is it suitable to do a servoectomy on a non servo bike? JJH

  4. #4
    Subscriber Click here to find out how to Subscribe
    Join Date
    Aug 2016
    Location
    West Sussex
    Posts
    1,723
    Quote Originally Posted by JJH View Post
    Is it suitable to do a servoectomy on a non servo bike? JJH
    All a 1200gs servectomy does is bypass the servo/ abs unit mechanically from the brake system - electrical functions are retained

    I could be wrong on the 1150 but this thread may give some pointers

    http://www.ukgser.com/forums/showthr...50-IABS-system

  5. #5
    Subscriber Click here to find out how to Subscribe
    Join Date
    Jun 2006
    Location
    Islandmagee, Co Antrim NI
    Posts
    9,524
    Servoectomy not needed on ABSII

    Pull blue relay in fuse box to stop lights flashing and have one steady red

    Really you need the codes read to see what is wrong

    It could just be a sensor gap or a damaged sensor cable?

    Did you have a very flat battery while away it may just need a reset?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Anyone attending a Ride Out or Event organised through the UKGSer Forums does so at their own risk.
UKGSer.com or anyone organising an event posted here will not be held responsible in any way for damage or personal injury sustained while attending any such events.

Members attending any such event do so at their own risk.

The text, images, graphics, sound files, animation files, video files, and their arrangement on this Website are all subject to copyright and other intellectual property protection. These objects may not be copied for commercial use or distribution, nor may these objects be modified or reposted to other sites without prior written permission.

Disclaimer: Use or depiction of the BMW logo or trademark throughout this web site is for illustrative and editorial purposes only, and to the benefit of the trademark owner, with no intention of infringement of the trademark.

The UKGSer Forums may include adult content for which it cannot be held responsible. Your use of this website constitutes acceptance of the UKGSER network privacy policy

"Its about being a grown up hooligan - and if that means a dark visor, remus open pipe and a bit of speeding out of town then all well and good"