Speedo reads 15 mph but the bike is not moving...

Captain GSA

Tosser Extraordinaire
UKGSer Subscriber
Joined
May 24, 2007
Messages
2,153
Reaction score
0
Location
A Greek island in The Aegean Sea
I was at Newlands today and as I was just pulling out onto the A25, I noticed that the bike’s speedometer was registering 15 mph even though it was not moving.:eek: In fact I wasn’t even on the bike at the time.:eek Granted the engine was running, the back wheel was even going round and round.:confused:
Now hold on, before you all start posting your solutions, rants or theories and ideas I need to explain. It might have had something to do with the fact that the bike was lying on its side after I dropped it......:eek:
Luckily help was at hand with a mate who helped me pick my bike up and I was on my way, a little warmer.... It is amazing how a little embarrassment raises the body temperature...:rolleyes:
A little oil seepage out of the air box, I think that is normal? Do I need to have a look and clean it? It seems to run fine. No damage, well no more than it already has...........:thumb2
 
bet u were busy watchin someone stood on there seat,an it distracted u:augie:D
 
bet u were busy watchin someone stood on there seat,an it distracted u:augie:D

Funny you should said that. We were talking today about how people on this forum remember things and then refer to them and throw them back into the pot after they have been long forgotten, forgiven or just moved on.......:augie

Have you got some kind of note pad or something.............?:eek:

.....oh....and thanks for your concern, I wasn't hurt either..........:thumb

:D
 
:blast Pap is the old age You will get use to it:rob
Try the spectsevers
Any damage?
 
Why is this posted under events, when it is in fact a drama.
 
Funny you should said that. We were talking today about how people on this forum remember things and then refer to them and throw them back into the pot after they have been long forgotten, forgiven or just moved on.......:augie

Have you got some kind of note pad or something.............?:eek:

.....oh....and thanks for your concern, I wasn't hurt either..........:thumb

:D

no, im just shallow,:D,,,,hope ur bikes ok:thumb
 
Glad you're OK - didn't loose it on the loop then:D:D

If its running OK you're good to go. I've had the bottom sparkplug caps loosed by a drop once which resulted in hesistation at full throttle.
 


Back
Top Bottom