Linux printing from Workstation to Server

snoopy

Guest
Server is running Cups server, all configured correctly.

Workstation has cups installed but rc.cups isn't running as not serving. KPrinter (KDE) can be set to use 192.168.3.2 (the server) and finds the printer and prints fine. Any program that writes to kprinter then works spot on.

But many programs use lp/lpr to print which isn't configured to use the server. How do I go about that?

I'm sure I'm missing something simple as I can't find anything on the internet. lpadmin adds/mods printers to cups server so not that???
 
man lp

...

-h hostname
Specifies the print server hostname. The default is "localhost" or
the value of the CUPS_SERVER environment variable.

so what's that set to then?

SEE ALSO
lpstat(1), CUPS Software Users Manual, http://localhost:631/documenta-
tion.html

Any clues in the manual? (actually on the mac it's just http://localhost:631/)
 
Tried all of that, the cups manual says lpoptions -d printer@server will set it.

But it doesn't.

Nothing works, tried finding something by google for an hour and no luck. Shit all else in the cups manual.

Solution found.

Symlinked lpr and lp to kprinter. Bollox to the lpr-cups and lp-cups files I'm letting KDE manage it.
 


Back
Top Bottom